[Solved] Problems after fresh install - live-boot

Forum rules
We don't support installations in VirtualBox, VMWare, qemu or others. We ignore posts about WINE, PlayOnLinux, Steam and Skype. We don't support btrfs, lvm, UEFI, side-by-side installations with GPT or dualboot with anything newer than Windows XP.
Google your problem first. Check the Wiki. Read the existing threads. It's okay to "hijack" an existing thread, yes! If your problem is not yet covered, open a new thread. To get the quickest possible help, mention the exact release codename in your post (uname -a is a good idea, too). Due to the lack of crystal balls, attach the output of lspci -nnk if you encounter hardware problems.
User avatar
RandomCharacter
Gangbanger
Posts: 323
Joined: Thu Aug 15, 2013 5:25 pm

[Solved] Problems after fresh install - live-boot

Unread post by RandomCharacter »

After a fresh install of Hot Dog, I had problems every time I tried to install anything. Here is a section of one log:

Code: Select all

Setting up linux-image-3.16-2-amd64 (3.16.3-2) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-3.16-2-amd64
cp: cannot stat ‘/lib/live/boot’: No such file or directory
live-boot: corecp: cannot stat ‘/lib/live/boot’: No such file or directory
E: /usr/share/initramfs-tools/hooks/live failed with return 1.
update-initramfs: failed for /boot/initrd.img-3.16-2-amd64 with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.16-2-amd64.postinst line 634, <STDIN> line 2.
dpkg: error processing package linux-image-3.16-2-amd64 (--configure):
 subprocess installed post-installation script returned error exit status 2
Setting up cpp-4.8 (4.8.3-12) ...
Setting up libgcc-4.8-dev:amd64 (4.8.3-12) ...
Setting up gcc-4.8 (4.8.3-12) ...
Setting up linux-compiler-gcc-4.8-x86 (3.16.3-2) ...
Setting up linux-headers-3.16-2-common (3.16.3-2) ...
Setting up linux-kbuild-3.16 (3.16-2) ...
Setting up linux-headers-3.16-2-amd64 (3.16.3-2) ...
Setting up linux-headers-amd64 (3.16+61) ...
dpkg: dependency problems prevent configuration of linux-image-amd64:
 linux-image-amd64 depends on linux-image-3.16-2-amd64; however:
  Package linux-image-3.16-2-amd64 is not configured yet.

dpkg: error processing package linux-image-amd64 (--configure):
 dependency problems - leaving unconfigured
Processing triggers for initramfs-tools (0.117.2~really~0.116) ...
update-initramfs: Generating /boot/initrd.img-3.13-trunk-amd64
cp: cannot stat ‘/lib/live/boot’: No such file or directory
live-boot: corecp: cannot stat ‘/lib/live/boot’: No such file or directory
E: /usr/share/initramfs-tools/hooks/live failed with return 1.
update-initramfs: failed for /boot/initrd.img-3.13-trunk-amd64 with 1.
dpkg: error processing package initramfs-tools (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.19-11) ...
Errors were encountered while processing:
 linux-image-3.16-2-amd64
 linux-image-amd64
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)

ERROR: apt-get install failed
After a good bit of searching and guessing, I removed packages live-boot and live-boot-initramfs-tools. The apt-get remove task continued and fixed the above installation problems, too.

Tim
Post Reply