(solved) Dash bug

Forum rules
Please supply only the affected package name as title, with bugreport number (bugs.debian.org) or other sources. This feed can be subscribed to and piped into your RSS reader or conky: http://linuxbbq.org/bbs/feed.php?mode=news
User avatar
doubledutch
killall X
Posts: 163
Joined: Sun Aug 10, 2014 1:25 pm

(solved) Dash bug

Unread post by doubledutch » Thu Jan 25, 2018 4:27 am

Per the following:
http://bugs.debian.org/888227
https://bugs.debian.org/cgi-bin/bugrepo ... =888180#17

Basically last night I went to do a bbq-style `upg`

Everything failed and (honestly without looking at or reading anything) I said ``who cares, I will try this again later, it is very late``
Then I went to alt+enter to open a terminal in usual i3 fashion. Nothing would open. This was to poweroff my machine... so I figure, whatever, and went to TTY2 and powered off from there.

So then I go to boot my machine this morning and everything went fine until `startx` (which I type manually for fun and profit) and received:
-bash: /usr/bin/startx: /bin/sh: bad interpreter: No such file or directory

The fix for this was to mv /usr/bin/dash /bin/dash

After doing so, I had to go into /bin and ln -s dash /bin/sh

Then after everything was nice and fixed, startx worked and ever so mysteriously my wireless adapter worked (while experiencing the bug the light would not turn on for it, like it was hard blocked or not enabled? weird...) and when I was back at nominal i3-session alt+enter once again opened urxvt-256er. Hooray.

So then I ran `upg` again and it wanted to update DASH! AGAIN?! OH NO.
But I updated it. And it was good.
Didnt have to change anything back... yet...

I wrote in debian-devel a little about how I was slightly tilted because I obviously misunstood what dash was and how it worked... but this has led to a wonderful learning opportunity for me.

Furthermore, this has inspired me to not only become more present in the LinuxBBQ community, but in the Linux community as a whole. Expect me to start contributing more and getting out to spread the good word and share my knowledge, rather than continuing to cinder-block and mortar the doorway to my third-floor basement lair into unusability (metaphorically and literally).

User avatar
ivanovnegro
Minister of Truth
Posts: 4869
Joined: Wed Oct 17, 2012 11:12 pm

Re: Dash bug

Unread post by ivanovnegro » Thu Jan 25, 2018 9:01 pm

An interesting one.

Seems to be solved so I mark it as such if nobody complains.

User avatar
wuxmedia
Grasshopper
Posts: 5902
Joined: Wed Oct 17, 2012 11:32 am
Location: UK
Contact:

Re: (solved) Dash bug

Unread post by wuxmedia » Thu Jan 25, 2018 9:21 pm

DD wrote: I obviously misunstood what dash was and how it worked... but this has led to a wonderful learning opportunity for me.
yeah hahaha. isn't it just that.
"Seek, and Ye shall find"
"Github | Chooons | Site"

Post Reply