[fixed] perl-modules (serious bug)

Forum rules
Please supply only the affected package name as title, with bugreport number (bugs.debian.org) or other sources. This feed can be subscribed to and piped into your RSS reader or conky: http://linuxbbq.org/bbs/feed.php?mode=news
User avatar
ivanovnegro
Minister of Truth
Posts: 5024
Joined: Wed Oct 17, 2012 11:12 pm

[fixed] perl-modules (serious bug)

Unread post by ivanovnegro » Sun Mar 01, 2015 2:11 pm


User avatar
dkeg
Configurator
Posts: 3782
Joined: Sun Nov 18, 2012 9:23 pm
Location: Mid-Atlantic Grill

Re: perl-modules (serious bug)

Unread post by dkeg » Sun Mar 01, 2015 2:28 pm

Yes, thank you! I see it this morning EST

Code: Select all

The following packages will be upgraded:
   libfreetype6 (2.5.2-2 => 2.5.2-3)
   libfreetype6-dev (2.5.2-2 => 2.5.2-3)
   libgnutls-deb0-28 (3.3.8-5 => 3.3.8-6)
   libgnutls-openssl27 (3.3.8-5 => 3.3.8-6)
   libllvm3.5 (3.5-9 => 3.5-10)
   libperl5.20 (5.20.1-5 => 5.20.2-1)
   perl (5.20.1-5 => 5.20.2-1)
   perl-base (5.20.1-5 => 5.20.2-1)
   perl-modules (5.20.1-5 => 5.20.2-1)
   python-pip (1.5.6-4 => 1.5.6-5)
   youtube-dl (2015.02.06-1 => 2015.02.28-1)

Work hard; Complain less

User avatar
ivanovnegro
Minister of Truth
Posts: 5024
Joined: Wed Oct 17, 2012 11:12 pm

Re: perl-modules (serious bug)

Unread post by ivanovnegro » Sun Mar 01, 2015 3:40 pm

Little workaround is to hold perl-modules and then:

Code: Select all

apt upgrade
Do not dist-upgrade!

machinebacon
Baconator
Posts: 10253
Joined: Thu Sep 16, 2010 11:03 am
Location: Pfälzerwald
Contact:

Re: perl-modules (serious bug)

Unread post by machinebacon » Sun Mar 01, 2015 5:51 pm

i upgraded blindly to 5.20.2-1, works :) will reboot later
..gnutella..

User avatar
ivanovnegro
Minister of Truth
Posts: 5024
Joined: Wed Oct 17, 2012 11:12 pm

Re: perl-modules (serious bug)

Unread post by ivanovnegro » Sun Mar 01, 2015 8:42 pm

Cool. Maybe it is really only a policy violation.

My concern was when you hold perl-modules and blindly d-u it will remove half of the building.

User avatar
dkeg
Configurator
Posts: 3782
Joined: Sun Nov 18, 2012 9:23 pm
Location: Mid-Atlantic Grill

Re: perl-modules (serious bug)

Unread post by dkeg » Mon Mar 02, 2015 12:08 pm

Looks to be fixed in

Code: Select all

   perl (5.20.1-5 => 5.20.2-2)
   perl-base (5.20.1-5 => 5.20.2-2)
   perl-modules (5.20.1-5 => 5.20.2-2)
which is available

Work hard; Complain less

User avatar
ivanovnegro
Minister of Truth
Posts: 5024
Joined: Wed Oct 17, 2012 11:12 pm

Re: [fixed] perl-modules (serious bug)

Unread post by ivanovnegro » Mon Mar 02, 2015 1:32 pm

Thanks.

/Fixed.

User avatar
vic
Godot
Posts: 1607
Joined: Wed Oct 17, 2012 10:11 am
Location: /other

Re: [fixed] perl-modules (serious bug)

Unread post by vic » Mon Mar 02, 2015 7:59 pm

Good here too. :)
Sorry guys, I am busy with my favorite K-drama.

User avatar
catfood
Haxxor
Posts: 125
Joined: Tue Oct 04, 2016 1:25 am

Re: perl-modules (serious bug)

Unread post by catfood » Fri Jul 10, 2020 5:18 am

ivanovnegro wrote:
Sun Mar 01, 2015 3:40 pm
Little workaround is to hold perl-modules and then:

Code: Select all

apt upgrade
Do not dist-upgrade!!!!!!!!!!!!!!!!
I know it's a dead thread, sorry, but you just saved my ass again. I almost reverted 3 days work trying to hold my kerenel and doing apparently another bad habit I need to unlearn!
Put a COW in your boxen bbq ;)
(If "Haxxor" stands for terrible Script Kiddie, then yes, astute observation!)

Post Reply