surf upgrade pulls in libgtk3

Forum rules
Please supply only the affected package name as title, with bugreport number (bugs.debian.org) or other sources. This feed can be subscribed to and piped into your RSS reader or conky: http://linuxbbq.org/bbs/feed.php?mode=news
User avatar
dkeg
Configurator
Posts: 3782
Joined: Sun Nov 18, 2012 9:23 pm
Location: Mid-Atlantic Grill

surf upgrade pulls in libgtk3

Unread post by dkeg » Sun Jan 10, 2016 2:28 pm

More of an FYI / heads up.
Looks like the newest version of surf, coming through today, has a gtk3 dependency.

Code: Select all

The following NEW packages will be installed:
   adwaita-icon-theme (3.18.0-2)
   libatk-bridge2.0-0 (2.18.1-1)
   libatspi2.0-0 (2.18.3-3)
   libcolord2 (1.2.12-1)
   libcroco3 (0.6.11-1)
   libgtk-3-0 (3.18.6-1)
   libgtk-3-bin (3.18.6-1)
   libgtk-3-common (3.18.6-1)
   libjavascriptcoregtk-3.0-0 (2.4.9-3)
   libjson-glib-1.0-0 (1.0.4-2)
   libjson-glib-1.0-common (1.0.4-2)
   librest-0.7-0 (0.7.93-1)
   librsvg2-2 (2.40.13-1)
   librsvg2-common (2.40.13-1)
   libwebkitgtk-3.0-0 (2.4.9-3)
   libwebkitgtk-3.0-common (2.4.9-3)
The following packages have been kept back:
   xserver-common (1.17.2-1.1 => 1.17.3-2)
   xserver-xorg (7.7+7 => 7.7+12)
   xserver-xorg-core (1.17.2-1.1 => 1.17.3-2)
The following packages will be upgraded:
   libcairo-gobject2 (1.14.4-1 => 1.14.6-1)
   libcairo-script-interpreter2 (1.14.4-1 => 1.14.6-1)
   libcairo2 (1.14.4-1 => 1.14.6-1)
   libcairo2-dev (1.14.4-1 => 1.14.6-1)
   libgnutls-deb0-28 (3.3.19-1 => 3.3.20-1)
   libgnutls-openssl27 (3.3.19-1 => 3.3.20-1)
   surf (0.6-1 => 0.7-1)
7 upgraded, 16 newly installed, 0 to remove and 3 not upgraded.
Need to get 42.5 MB of archives.
After this operation, 117 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
Edit: Yep, seems so

Code: Select all

The following packages have been kept back:
   surf (0.6-1 => 0.7-1)
   xserver-common (1.17.2-1.1 => 1.17.3-2)
   xserver-xorg (7.7+7 => 7.7+12)
   xserver-xorg-core (1.17.2-1.1 => 1.17.3-2)
The following packages will be upgraded:
   libcairo-gobject2 (1.14.4-1 => 1.14.6-1)
   libcairo-script-interpreter2 (1.14.4-1 => 1.14.6-1)
   libcairo2 (1.14.4-1 => 1.14.6-1)
   libcairo2-dev (1.14.4-1 => 1.14.6-1)
   libgnutls-deb0-28 (3.3.19-1 => 3.3.20-1)
   libgnutls-openssl27 (3.3.19-1 => 3.3.20-1)
6 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 3,382 kB of archives.
After this operation, 2,048 B disk space will be freed.
Do you want to continue? [Y/n] 

Work hard; Complain less

machinebacon
Baconator
Posts: 10234
Joined: Thu Sep 16, 2010 11:03 am
Location: Chinkistan
Contact:

Re: surf upgrade pulls in libgtk3

Unread post by machinebacon » Sun Jan 10, 2016 2:40 pm

libwebkitgtk-3.0-0 (2.4.9-3)

Blame this package for all the gtk3 stuff coming in :)
..gnutella..

User avatar
dkeg
Configurator
Posts: 3782
Joined: Sun Nov 18, 2012 9:23 pm
Location: Mid-Atlantic Grill

Re: surf upgrade pulls in libgtk3

Unread post by dkeg » Sun Jan 10, 2016 3:35 pm

yes, dwb already has suffered this fate long ago. Vimb luckily is backward compatible and compiles with libgtk2, surf also did, but now not so lucky. I barely use surf so no harm, but it is a shame to see thats for sure.

Work hard; Complain less

machinebacon
Baconator
Posts: 10234
Joined: Thu Sep 16, 2010 11:03 am
Location: Chinkistan
Contact:

Re: surf upgrade pulls in libgtk3

Unread post by machinebacon » Sun Jan 10, 2016 3:49 pm

yes yes, seems :uzbl: is still GTK2 only, and the iceweasel wrapper :conkeror:
xombrero/xxxterm is also on the GTK3 trip

A pity that they don't offer GTK2-alternatives in the Debian repos.
..gnutella..

User avatar
dkeg
Configurator
Posts: 3782
Joined: Sun Nov 18, 2012 9:23 pm
Location: Mid-Atlantic Grill

Re: surf upgrade pulls in libgtk3

Unread post by dkeg » Sun Jan 10, 2016 4:03 pm

Yes, true for xxxterm and xombrero, shame. My last experience with uzbl was awful, consistent crashes. Conkeror is also a very nice browser.

Work hard; Complain less

Post Reply